Official 'Avencast - Rise of the Mage' discussion board
It is currently Thu Jan 18, 2018 5:14 am

All times are UTC + 1 hour

Post new topic Reply to topic  [ 80 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6
Author Message
 Post subject: Re: Problems at the Planetarium
PostPosted: Sat Sep 20, 2008 11:40 pm 

Joined: Sat Sep 20, 2008 11:15 am
Posts: 17
Nukl3ar wrote:
I'm having a similar problem to the one others have posted here. I aim the beam at the crystal on the signalling machine ... pull the lever and hear a clicking sound. Nothing else happens. I've got games saved where I send the beam directly from the south tower to the west & also a game saved where I send the beam from the south tower to the east then north and finally west. I've saved and exited and restarted many times. Has anyone got a suggestion? If I end up being stuck here I will probably abandon this game ... I've deleted all saved games more than a day or so old. Any help would be appreciated.

Theri is a post from guy "Maximus" on 4 page there U"ll find 3 separate wallkthu first Chapter 1 then in 2 2,3 & 4 chapter and last 4,5,7 take it look there and U find all the hints how ,where to resolve problems,I find that very helpful . sambo-5 on that 4 page of this forum go to 4 page and click on Bags fixes folow it litle down and there will be those wlk thru ofers I save them to my desktop so I got easy axses to them when I need them,good luck
Sam :D

 Post subject: Re: Problems at the Planetarium
PostPosted: Sun Sep 21, 2008 12:08 am 

Joined: Sat Sep 20, 2008 11:15 am
Posts: 17
Andrenalin wrote:
Yo :)
hoped you guys could give me some tips for how to solve this "puzzle". So according to my questlog, I have the key for the Planetarium and I'm in there. ok, so here what I've managed to do so far;
- Found the red star, getting the beam.
-Placed all the mirrowmachines in the other rooms so they get the beam and send it to the next room...

There is two levers in two different rooms afaik. One of them dont do anything and is next to some sort of machine, but when I press this I get the message that I need some objektiveitem. The other one I get the message that the machine doesn't have energy!
I've been EVERWERE to search for clues, keys, anything. Im just so stuck and frustrated. I want to keep playing this awesome game :)
So please help! :))
Here are walkthru for 1 chapter hope that help...sambo-5 :D
Avencast Examination Walkthrough
Class Awakening
AVENCAST starts with a story in Layered Water Pastel. After a short ‘embarrassing’ dialog, Xivarious send you to your mentor Malvaren. Pick up the manual from the table next to you and your Staff before leaving the room. Malvaren requires you to collect 3 seals. (Received Parchment of 3 seals, Map of Seminar Rooms)

Horatio’s Seal Quest.
Killing the 1st and 2nd sets of mob gains you (100 experience)
You will have to kill the 3rd and 4th sets of monsters gains you (120 experience) and Horatios’s Seal. The 5th set will gain you (100 exp and Horatio’s Bracers –> D+4, MA+4, BM+2, HP+4)

Subquest – Beating up the bully.
Rufus who stands near Horatio at the Arena will challenge you to duel for 5 guilders given to the winner. Winning 1st round earns you 5 exp and a Bread Roll (restores 400 HP). You will get 5 guilders if you accept a rematch. Winning again earns you 5 exp and 5 more guilders. If you extort him for 10 guilders, he will call Horatio and get away with it.

Subquest – Severin’s Imp Outbreak
Kill all the imps in the library and clear the rats and spiders in the corridors and rooms. You will receive 20 Guilders for the quest.

Subquest – Georgius gone Invisible
His room is located opposite Della Gusta’s History Lecture Hall. Go to the Spinning Globe to get the quest. Go to Xivarius to get the Visibility Potion in the Alchemy Hall. Making Georgius visible again earns you 40 Guilders and 80 Exp.

Subquest – Dolcina’s Pink Imp Ran Away.
She stand near some Red Sofas at the left side of the Center Courtyard. Go to South Eastern wing of the School Near Kelios’s Lab. In the room left of this block you will see a room with 2 smaller rooms with many tables in them. Pulling all the levers in all 3 rooms Once each, will open the route for the imp to the cage. Then you may start chasing the imp to Its cage. Shut the gate after the imp returns to Its cage. Return to Dolcina for your reward. (150 exp, Dolcina Cord of Quick Wit – MA+1, SM+5, Max Mana+10, MR+1)

Subquest – Steal a book for Gorlin the Merchant
Gorlin is located north section of the Center Courtyard. He wants you to get a book The Black Sparkling Tiger for him from the library. Go to the Library at the south west Wing of the Great Halls. Avoid the librarian while searching to the book in all the shelves. The book is located randomly. Return to Gorlin after locating the book. You will gain 100 experience, Gorlin’s Magic Trading Scroll and Gorlin Rainbow Ring.

Subquest – Hubertus Lost his Bag of Crystals.
Hubertus is one of the student in Archibald’s Class. Find his Crystals in the Garden. The bag is near the entrance to Crystal Cave. Return to Hubertus and he will give you a piece of Sparkling Crystal and 50 experience.

Subquest – Swiftlina’s Big Boast
You will meet Swiftlina near a Lily Pond in the Garden. She will challenge you to speed ranged targeting. Shoot all the moving target within 10 seconds will earn you 10 guilders. She then challenges you to do it in 5 seconds for another 10 guilders.

Archibald’s Seal
Talk to Archibald in his Class room South West of the Academy. He instructs you to get a potion for Kalios to tame the 2 trees. Go to Kalios’s Lab and he will ask you to pick up the Ice Spray in the storage room. Return the lab after getting the spray. Use the Spray on the Fire Dwarfs. Killing all the Dwarfs Gain you 50 exp and the Fertilizer. Taking on the 2nd quest (Pot Cooling quest) which requires you to use the Ice Spray on the pots to prevent them from eruption. Its possible, just takes lots of patience and calm. You’ll just need to keep cooling the pots with the ice spray for approximately 2-3 minutes. After lots of cursing and swearing, you gain an additional 100 exp for the trouble. (the game’s most annoying mini-quest)

Take the Fertilizer and go to the Garden. Avoid killing the Killer Branches and use the Fertilizer on both Trees by Pressing ‘E’ near them. Then kill all the remaining Killer Branches. Return to Archibald to get the seal. You will gain 150 experience.

Della Gustera’s Seal (THE CRYPT)
He can be found in his Class Room North West of the Acedemy. He wants you to Restore Peace in the academy’s Crypt. Proceed to the Garden and Enter the Crypt at the right side of the garden.

Upon entering the Crypt, you will find a Stone Platform and a lever. Pull the Lever to move the Platform. Proceed to the next room. Kill every monster you find in the Crypt. Talk to Istaros to get Clues on his ‘Treasure’. Clear all the rooms of Monsters then pull the northern Lever to move the Platform forward. Kill all the Monsters here. Then proceed to the left room. At the south of this room you will find a Wall plate that says ‘Here Lies Dagrius. He died trying to walk through a wall.’ Walk into the wall and you will come to a room where you will find the FIRE RESIST potion. Go back to the Center Courtyard and enter the North West Gate.

Walk along the outer side of the bridge to get across the ILLUSION BRIDGE. Here you will find the History Book of Uldret and Pagain. (Clues for the Candle Stand). Use the FIRE RESIST potion to pass the Fire Wall. Rush in, Grab all the things in the Grave and Run out. Use the ICE SPRAY to freeze the water blocking the path to a room. Return to Center Courtyard after killing everything and scavenging. You gain 100 exp for crossing each hurdle

Clear the mobs and scavenge everything in the room on the right. Then proceed through the north east Gate. Here u will find a Candle stand. Enter the 2nd Code you see in the History Book of Uldret and Pagain. (kinda looked like P^b^J/ ) You gain 100 exp for breaking the code. In the room where there are alphabet on the floor, Step on the tiles in this order ‘ M A R U G A R M A G I C U S ‘ and you get a free 100 exp. Walk the reverse way when leaving the room to avoid being hit by the Lightning trap. In one of the rooms you’ll see a Wall Plate saying ‘Here Lies Marcus, the Hidden One’. Walk through the wall here and you will find 1 Minor Healing Potion and one Minor Mana Potion.

One of the Skeleten has the Missing Lever here. At the end of the corrider is a lock gate. Use the lever nearby to Open this gate. Then return to the center courtyard, where a bulk of newly spawned Skeletons awaits to plummet you. Don’t let them. After clearing this infestation, Use the Missing Lever at the Lever Switch. (160 exp) Then Pull it to move the Platform to the last room.

Here you will find Tertius – Your First Boss Mob. Kill him first. (80 exp) Then clear all the other monsters. Pick up his Dead Carcass and place it on the Stone Platform. Then move to platform by pulling the respective Levers to the place where you see 2 Dragon Statue. When the platform arrive, Pull the lever behind the Dragon Statue to Cremate Tertius. (500 exp). Upon his death, You can access his Coffin for some goodies. Take everything in Tertius chambers and then return to Della Gusta in the Academy Seminar Rooms to get your final Seal.

Return to your Mentor Malvaren for the Final Trial in the Crystal Cave.

Crystal Cave
You will be brought to the Cave entrance. Inside the Cave you will see a Lightning Barrier. It will Kill everything that passes through it, you included. If you find killing the monsters too tedious, you can always lure them to the lightning barrier. At the left of the cave you will find a camp fire with dead bandits around it. Pick up the Old Wooden Planks (Quest Item) and the Crystal (Quest Item) from the Dead Bandit.

You will come across a round opening on the right side of the map. Here you will fight a Mini Boss The SPIDER QUEEN. Her Poison are very lethal. So keep you distance. Spawn a Minion and only attack her when she is distracted. Then leave the cave area to recharge mana or restore Hit Points. Repeat until she is dead. There is a change she might Heal herself so don’t worry. Probably a Bug or not, I take it as one of her skills. She will drop the Spider Queen Staff (Dmg +36, Poison +20 per second, Recoil 20) and Spider Gland (Quest item)

At the North West side of the Cave, you will find a LOCKED COFFIN. Ignore it for now. At the Center of the Cave you will come across a Broken Bridge. Use the Spider Gland and Old Wooden Planks on it to get across. There you will find Shandri, who will give you a GOLDEN LEVER and 250 exp. Now you can use the GOLDEN LEVER to open the LOCKED COFFIN. There are equipment inside but I thinks the stats are random.

As you proceed to the Northen part of the Cave, you will come across a pair of Lightning Barriers and a GIANT CRYSTAL CRAB. Firstly, place the missing Crystal in both Barrier Generators. Then go to the place where the Crab Emerges from the fuming ground. Notice on the right side are some POTS, press ‘E’ at the POTS to spill the OIL onto the Ground, then you could set fire to it by using a ranged soul magic. The Crab will emerge again and will not burrow anymore, and will chase you. Quickly run pass the LIGHTNING BARRIER and turn it ON. The Great Giant Crab will be fried. If only it can be eaten,... Yummy !!. Anyway, the consolation is, you get a Crab Mask (Defence+26, MA+12,BM+4, HP+8 ). Proceed North to next map.

Deep in the Crystal Cave.
The left of the cave have many Crystal Golem. These creatures have very high atk power and defence. Always sent out a Minion as you proceed. Nuke them as your minion distracts them. At the Top right of this cave you will find Your SOUL STONE. You can access the fenced area at the center left through the North West side of the Cave. Here you will see a Wrecked Gate with a dead Crab under it. Use the Red Crystal to revive the Crab. The gate will crumble to pieces. Kill the Crab and proceed. The Treasure box will give you a Sash and a decent pair of Boots.

Proceed to the center top of the cave. You will meet a scary Golem – He Anrail. Luckily we don’t need to fight him. Choose the Left Exit if you want to pursue Soul Magic or Choose the Right Exit if you want to Become a Blood Mage.

Soul Path
Kill the Scorpions along the way. You will see a Lever behind a Stone Dragon. Pulling it will reveal a hidden Treasure room. Take the Goodies and proceed. You will soon come across 2 Elemental Lizards locks behind bars. Lure the Ice Element to the Chamber and Lock it in. Go to the set of Pipes Top left of the room. Then turn the Crank Wheel and set the levers to @ / / \ in this manner (@ = the Crank Wheel) The Heat will Kill the Ice Element. Pick up the Ice Flower Crystal. Now Lure the Fire Element into the same chamber and Lock it it. Then go to the set of Pipes Top Right of the room and Turn the Crank Wheel and set the levers to \ / / @. This will Kill the Fire Element. Pick up the Fire Pearl. Now proceed to the Chamber Right of this room. Place the both Elemental Crystals on the Stand. The door will Open. Now Pick up the crystals and and enter this room. At the Center you will see a stand with 3 slots. Place your Soul Stone, the Ice Flower and the Fire Pearl on it. Then Turn on Both Crank Wheel to and set the levers in this order. @ / \ / / \ / @ . Return to the chamber and collect your Magic Embedded Soul Stone. – End of Chapter –

Blood Path
Kill all the Golems you find in this maze. There are some Poorly Erected Barriers which will crumble with a simple hit. Break all the Barriers. Make your way to the Top of the Maze. There you will have to Defeat the Giant Crystal Golem. The Spider Queens Poison Staff works excellently here. Upon Killing the Golem, The New Chapter will begin.

The Fall of Avencast

You return to Avencast but the place is no longer the same. Monsters have over-run Avencast. In the magic barricated room, Theodosius asks you to find an item from a monster for him. Kill the monsters outside and return to Theodosius with the ......

 Post subject: Re:
PostPosted: Sun Sep 21, 2008 12:34 am 

Joined: Sat Sep 20, 2008 11:15 am
Posts: 17
LawGuy wrote:
I seem to have the same problem that a few of the earlier posters in this thread have.

I'm on the signaling quest (first quest to use the planetarium), and get the blue beam through the South room to the West room and onto the signaling machine. This makes the machine's crystal light up all nice and pretty.

I then walk over to the signaling machine and pull the lever, but get a "Locked" message.

What am I missing here?

sambo-5 If U have beams lin up cprrectly do not pull lever yet go front of that clos dish there and click E openet ,it "ll open ,put that cristal in and then pul that liver beside The machine statart recharging that cristal but during that charge ,the monster will apear in telescop room and change aliment go there fight with him kill him and realine a everiting as befor only in that room then go back and finish recharging that cristal ,now U"ll be no interaption ,after recharging get that cristal to person who ask U to do that ,mission acomplish sambo-5 ...Sam

 Post subject: Re:
PostPosted: Sun Sep 21, 2008 12:53 am 

Joined: Sat Sep 20, 2008 11:15 am
Posts: 17
LawGuy wrote:
I am positive that I did the exact same thing I was doing before. Once I got the beam on the crystal, I didn't move it. When I got the bug, I ran back to the library, saved my game, exited, and popped on the forum. Once I saw Persuader's post, I loaded up my game and ran right back to the same room, with the beam still there, and pulled the lever, expecting to get another "Locked" message. Instead, it worked, so I saved and hopped back on here to post.

On my game, the signal machine is in the West room, as indicated by both the little "quest item here" thingy in my mini-map (Excellent feature, BTW), and by the fact that it worked this time. The path for the beam was South then West for me, which matches the description someone else posted earlier. Maybe the paths are reversed in different localized versions? I can post a screenshot with a close-up of the mini-map if you'd like me to, just to make sure that my problem wasn't caused by my character living in a backwards world. :)

Thank you to both of you for the help!


 Post subject: 1st post here
PostPosted: Sat Oct 31, 2009 3:57 pm 

Joined: Thu Oct 15, 2009 4:21 pm
Posts: 1
Just wanted to say hello all. This is my first post.

I hope to learn a ton here.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 80 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6

All times are UTC + 1 hour

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group